3.2.77

Upgrade Notes

The notes supplied here pertain to upgrading to Cloud CMS version 3.2.77.

Elastic Search Client

Make sure that you are have configured Cloud CMS to connect to Elastic Searching using the condor HTTP/S client.

In prior versions of Cloud CMS, an http and transport client were offered that utilized the native drivers of Elastic Search. As we've expanded our support for Elastic Search to include Amazon OpenSearch, we've moved over to using the condor driver which is built and optimized for HTTP/S interaction to both environments.

As such, the legacy Elastic Search Transport and HTTP drivers are no longer supported.

You will need to configure your Cloud CMS cluster to use the condor driver and connect to Elastic Search via its HTTP endpoint. This is typically a different port (9200) than the one used by the Transport client.

For information on configuring Elastic Search for Cloud CMS, please see: https://www.cloudcms.com/documentation/docker/configuration/api-server.html#using-the-condor-http-client

Upgrade

With Cloud CMS 3.2.77, we offer an upgrade tool that you can use to ensure that your installation is properly configured and optimized.

This upgrade tool is provided as part of the Cloud CMS Command Line Client. You can learn more about the client here: http://www.cloudcms.com/documentation/cli.html

You will need to install the Cloud CMS Command Line Client and configure it to connect to your Cloud CMS installation. Make sure that your Cloud CMS installation is up and running (on the new version of Cloud CMS) before using the tool.

You can then run the following:

cloudcms upgrade check --username <username> --password <password>

Where username and password are the credentials for your admin user.

This will check your installation to determine whether any upgrade steps are required.

If the check determines that upgrade steps are required, you can run them like this:

cloudcms upgrade apply --username <username> --password <password>